PHPMotion インストール.sh for CentOS 5.2

この前ので問題なくできるだろう。って思ってたら、最近ffmpegのlibavcodecか何かに変更があったようで、ffmpeg-phpのmakeが通らなくなっていました。

ということでそれの修正Ver。

ダウンロード:phpmotion_for_v2.1_0327.sh.txt

日本語化などはしてありますがこんな感じに。

http://menta.orz.hm/video/

変更点は上に書いたとおり、ffmpeg-phpのVer変更のみですが。

「PHPMotion インストール.sh for CentOS 5.2」への3件のフィードバック

  1. 初めてコメント記入させていただきます。
    いつも勝手ながら参考にさせていただいております。
    大変恐縮ですがアドバイスをいただけましたら大変ありがたく存じます。

    こちらのサイトにあるphpmotion_for_v2.1_0327.shを実行しまして、http://○○○/video/setup/にアクセスしましたところ、
    PHP script /var/www/html/video/classes/config.php is protected by phpSHIELD and requires the phpSHIELD loader phpshield.5.2.lin. The phpSHIELD loader has not been installed, or is not installed correctly. Please visit the phpSHIELD php encoder site to download required loader.
    というメッセージが出て参りました。phpshield.5.2.linをどこにアップしたら良いのでしょうか。

    参考までに。
    CentOS5.3
    PHP5.2
    phpmotion2.1

    厚かましい質問ですが、どうぞよろしくお教えいただきたくお願い申し上げます。

  2. コメントありがとうございます。

    PHPMotionで使うphpSHIELDのディレクトリは、phpmotion_for_v2.1_0327.shを使用した場合
    ”/var/www/html/video/phpshield”
    になります。

    phpSHIELDをディレクトリにアップロードする際の注意としては、
    ”/var/www/html/video/phpshield/phpshield.○.○.lin”及び”/var/www/html/video/classes/config.php”

    ”バイナリモード”
    でアップロードしないとエラーになります。
     
    また、
    ”/var/www/html/video/phpshield/phpshield.○.○.lin”
    にアップロードするだけでは認識しない場合もありますので、
     
    1.Apacheの再起動
     ex)/etc/init.d/httpd restart (reload)
     
    1の後にも認識されない場合
     
    2./etc/php.ini内に
    ”extension=/var/www/html/video/phpshield/phpshield.○.○.lin”
    もしくは
    ”extension=/var/www/html/video/phpshield/phpshield.○.○ts.lin”
    を追記し、Apacheを再起動させてみてください。

コメントを残す