friio@centos

必要なソフト(ライブラリのインストール)

yum -y install gtk+ gcc-c++ libusb-devel hal-devel glib2-devel boost-devel pcsc-lite ccid pcsc-lite-devel ccid-devel

参照サイト:ここだよっと(http://blog.kokodayo.com/2008/09/44.html)

DTV関連ツールのFriioうpろだから0777.zipをダウンロード

wget http://2sen.dip.jp/cgi-bin/friioup/source/up0777.zip
unzip 0777.zip
cd recfriior4/arib25v021/arib25/
make
cp src/b25 /usr/local/bin/b25
cd ../../recfriior4
vi Makefile
-mtを削除
:wq
vi usbops.hpp
・usb/ch9.h
↓へ変更
・usb_ch9.h
:wq
make
cp recfriio /usr/local/bin/recfriio
cd /usr/lib/pcsc/drivers/ifd-ccid.bundle/Contents
cp Info.plist Info.plist.org
cp /root/recfriior4/arib25v021/libccid_Info.plist Info.plist
vi Info.plist
<key>CFBundleExecutable</key>
<string>libccid.so.1.3.1</string>
<key>ifdManufacturerString</key>
<string>Ludovic Rousseau (ludovic.rousseau@free.fr)</string>
<key>ifdProductString</key>
<string>Generic CCID driver v1.3.1</string>
の1.3.1を自分のverに変更
recfriio --b25 25 10 out.ts
bcas->init failed. code=-4
disable b25 decoding.
Search friios from dir: /dev/bus/usb
1 friios found:
/dev/bus/usb/001/016: use this friio.
device: /dev/bus/usb/001/016
Signal level: 11.225
Output ts file.

 

…orz

 

これらの操作をDebian 5.0でやると普通にb25を通し複合化されたものが出力されるんだけどCentOS 5.2でやるとエラー。

ってことはFriioのカードリーダ自体はまぁ動いてるというかLinuxでも使えるんだろうけど。

つまりccidやpcsc関係ライブラリが足りないのかなぁ。

 

とか思いつつもういろいろいじくるのめんどくさくなってきたのでamazonでカードリーダ頼んでおきました。

コメントを残す